Skip to main content

Configuration de l'Etherchannel

Etherchannel permet l’agrégation de lien. Il est utilisé pour augmenter la bande passante entre deux switchs.

Introduction

Nous allons utiliser la topologie suivante :cisco-lacp.png

LACP

Configuration sur le 3750

3750#conf t
3750(config)#interface range fastEthernet 1/0/1 - 2
3750(config-if-range)#channel-protocol lacp
3750(config-if-range)#channel-group 1 mode active

Configuration sur le 3550

3550#conf t
3550(config)#interface range fastEthernet 0/1 - 2
3550(config-if-range)#channel-protocol lacp
3550(config-if-range)#channel-group 1 mode active

Vérification

3750#sh interfaces port-channel 1
Port-channel1 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 2037.0606.7484 (bia 2037.0606.7484)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Fa1/0/1 Fa1/0/2
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:21:40, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     1153 packets input, 132950 bytes, 0 no buffer
     Received 895 broadcasts (0 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 895 multicast, 0 pause input
     0 input packets with dribble condition detected
     490 packets output, 66172 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
3750#
  • Ligne 2 : Le port-channel 1 est passé UP
  • Ligne 4 : BW (bandwidth) est à 200Mbps (2x100Mbps)
  • Ligne 9 : Membres Fa1/0/1 et Fa1/0/2
PAGP

Le PAgP est un protocole propriétaire Cisco. Il se configure comme suit :

Configuration sur le 3750

3750#conf t
3750(configure)#interface range f1/0/1 - 2
3750(configure-if-range)#channel-group 2 mode auto
3750(configure-if-range)#end

Configuration sur le 3550

3550#conf t
3550(configure)#interface range f0/1 - 2
3550(configure-if-range)#channel-group 2 mode desirable
3550(configure-if-range)#end

Vérification

3750#sh etherchannel summary
Flags:  D - down        P - in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
2      Po2(SU)         PAgP      Fa1/0/1(P)  Fa1/0/2(P)

3750#
Load Balancing

Vérification du mode de load balancing

3750#sh etherchannel load-balance
EtherChannel Load-Balancing Configuration:
        src-mac

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
  IPv4: Source MAC address
  IPv6: Source MAC address

3750#

Ici la répartition de la charge s'effectue par l'adresse mac source. Ce paramètre est modifiable en fonction du niveau de votre switch. Au niveau 2 la répartition peut se faire à partir des adresses mac et au niveau 3 via les adresses mac et/ou adresse ip.

3750(config)#port-channel load-balance ?
  dst-ip       Dst IP Addr
  dst-mac      Dst Mac Addr
  src-dst-ip   Src XOR Dst IP Addr
  src-dst-mac  Src XOR Dst Mac Addr
  src-ip       Src IP Addr
  src-mac      Src Mac Addr

3750(config)#port-channel load-balance

Le 3750 étant un switch de niveau 3, j'ai accès à tous les modes.

Agrégation de niveau 3

Cette partie est en bêta

Configuration sur le 3750

3750(config)#interface range fastEthernet 1/0/1 - 2
3750(config-if-range)#channel-group 3 mode on
3750(config-if-range)#no switchport
3750(config-if-range)#exit
3750(config-if)exit
3750(config)#interface port-channel 3
3750(config-if)#no switchport
3750(config-if)#ip address 10.0.0.1 255.255.255.0
3750(config-if)#no shutdown
3750(config-if)exit
3750(config)ip routing
3750(config)router ospf 1
3750(config-router)#network 10.0.0.0 0.0.0.255 area 0
3750(config-router)#exit
3750(config)#do wr

Configuration sur le 3550

3550(config)#interface range fastEthernet 0/1 - 2
3550(config-if-range)#channel-group 3 mode on
3550(config-if-range)#no switchport
3550(config-if-range)#exit
3550(config-if)exit
3550(config)#interface port-channel 3
3550(config-if)#no switchport
3550(config-if)#ip address 10.0.0.2 255.255.255.0
3550(config-if)#no shutdown
3550(config-if)exit
3550(config)ip routing
3550(config)router ospf 1
3550(config-router)#network 10.0.0.0 0.0.0.255 area 0
3550(config-router)#exit
3550(config)#do wr

Vérification de l'OSPF

3750#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
172.16.3.202      1   FULL/BDR        00:00:30    10.0.0.2        Port-channel3
3750#
3750#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.3.0 is directly connected, Vlan1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, Port-channel3

Test de ping entre les deux switchs

3750#ping 10.0.0.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
3750#